Forum Join our community

Language Switcher gives me a 404 error

  1. Critical
  2. Uwe
  3. -
  4. Bugs & Issues
  5. -
  6. Monday, 18 March 2019
  7. -
  8.  Subscribe via email
0
Votes
Undo
Hi,

I am running a site with two languages (English and German) which can be changed by the Falange Language Switcher. In TZ Portofolio I have created Categories and Articles for each of these languages. In my menu I have created the respective menu items for both languages.

When I call a single article it is only possible to switch the language from German to English. When I am switching from English to German I am getting 404errors.

So when I switch from http://mysite.com/german-article to English the URL changes from http://mysite.com/en/english-article. This is correct and it works well.

But when I switch from http://mysite.com/en/english-article to German the URL changes to http://mysite.com/english-article. So the only thing that changes is that /en/ disappears from the URL. That is not correct. Also the rest of the URL should change to .../german-article. But this does not happen.

What am I missing?

Regards,
Uwe
Comment
There are no comments made yet.
Accepted Answer
Uwe Accepted Answer Pending Moderation
  1. Friday, 22 March 2019
  2. -
  3. # Permalink
0
Votes
Undo
Hi Sonny,

No I did not solve the problem. Instead I switched from TZPortfolio to Joomla articles which give me more flexibility.

Thanks for following up.

Regards,
Uwe
Comment
There are no comments made yet.
Sonny Accepted Answer Pending Moderation
  1. Monday, 18 March 2019
  2. -
  3. # 1
0
Votes
Undo
Hello,

May you send me your admin login via [email protected]? I will help you check it.

Thanks & Best Regards,
Sonny
I am Sonny! A farmer at TZ Portfolio+ Team :D
Please vote for TZ Portfolio on JED ;)
Comment
There are no comments made yet.
Sonny Accepted Answer Pending Moderation
  1. Friday, 22 March 2019
  2. -
  3. # 2
0
Votes
Undo
Hello,

Did you solve your issue? I don't received any email from you. Please inform me if you solved this issue.
This topic will be marked solved after 24h.

Thanks & Best Regards,
Sonny
I am Sonny! A farmer at TZ Portfolio+ Team :D
Please vote for TZ Portfolio on JED ;)
Comment
There are no comments made yet.
Sonny Accepted Answer Pending Moderation
  1. Friday, 22 March 2019
  2. -
  3. # 3
0
Votes
Undo
Hi Sonny,

No I did not solve the problem. Instead I switched from TZPortfolio to Joomla articles which give me more flexibility.

Thanks for following up.

Regards,
Uwe


Thanks for your response. Please tell me if you need further assistant.

Best Regards,
Sonny
I am Sonny! A farmer at TZ Portfolio+ Team :D
Please vote for TZ Portfolio on JED ;)
Comment
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Share Location

Sharing your current location while posting a new question allow viewers to identify the location you are located.

Latitude:
Longitude: