Friday, 31 March 2023
  8 Replies
  1K Visits
0
Votes
Undo
  Subscribe
Hi,
i`ve just installes TZ Portfolio.
I´ve added some articles and published them with "TZ Flex Grid"-modul on my page.
All words finde, except of the message that appears right above the module.

Warning: foreach() argument must be of type array|object, null given in Z:\xampp\htdocs\graffiti\administrator\components\com_tz_portfolio_plus\tables\templates.php on line 66

TZ Portfolio Plus Version 2.6.4
TZ Flex Grid Version 1.0.4

How could i solve this issue?

Unfortunatly i can`t provide you a login because im currently using xampp...

Peter
1 year ago
·
#3232
Accepted Answer
0
Votes
Undo
Hi,
sorry for my late reply.
Seems like i solved the problem.
I´m using RS Page Builder to display some images using the TZ Portfolio+ module.
Other non-published elements from rs page builder were present in the rs page builder-page. they seem to have caused the problem.
Hi, where did the warning appear, in the backend or front-end?
Could you turn on the debug system and send me a screenshot?
1 year ago
·
#3137
0
Votes
Undo
Thank you, just sent you a pn.
The error appears on the front-page.
Hi, which template styles did you assign to the module?
Plz make sure the style is already up-to-date.
1 year ago
·
#3145
0
Votes
Undo
Hi,
just made some more screenshots.
All components should be up-to-date.
Maybe you need to know that i`m using the asteroid framework?!
1 year ago
·
#3150
0
Votes
Undo
Just updates TZPortfolio+ to version 2.6.5 but the error ist still there
Warning: foreach() argument must be of type array|object, null given in Z:\xampp\htdocs\graffiti\administrator\components\com_tz_portfolio_plus\tables\templates.php on line 66

Screenshot: https://prnt.sc/9r0-uHqa_3Md


At the backend i found another error in the module: TZ Portfolio Plus Portfolio
Warning: foreach() argument must be of type array|object, null given in Z:\xampp\htdocs\graffiti\administrator\components\com_tz_portfolio_plus\tables\templates.php on line 66

Screenshot: https://prnt.sc/Klqyu6IpupI6

if i delete line 66-68 in tables\templates.php all seems to be fine.
What does these lines do?
Hi, sorry for the late reply.
Regarding the issue, plz contact me via live chat window and I can help you check the issue by connecting via team viewer or other remote control tools.
1 year ago
·
#3232
Accepted Answer
0
Votes
Undo
Hi,
sorry for my late reply.
Seems like i solved the problem.
I´m using RS Page Builder to display some images using the TZ Portfolio+ module.
Other non-published elements from rs page builder were present in the rs page builder-page. they seem to have caused the problem.
It's so good to hear that :)
  • Page :
  • 1
There are no replies made for this post yet.
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below.
Supported: gif,jpg,png,zip,rar
· Insert · Remove
  Upload Files (Maximum 2MB)

Sharing your current location while posting a new question allow viewers to identify the location you are located.

Login